Skip navigation
Banner: Programming or technical problem? Click to Ask the Experts.

Motorola CP185

Post

Does not boot up

Hi!

I have a Motorola CP185 America editon VHF who dows not boot up..
Battery full charge, no lcd, no beep, no motorola boot up sound, no sound on channel change, no sound on ptt, no lights at all

Does it have a internal fuse or something?

Thanks!
Back to the top

Post

Could be quite a few things going on. If there is absolutely, 100% not turning on in any way shape or form. You likely have a volume potentiometer issue, a battery contact issue, or a power protection fuse blown. Maybe a dissconnect from the internal flex cables on the housing.
Back to the top

Post

ok, I lied about "nothing".. I mean.. nothing except a "pokkk" sound in the speaker when I turn on the radio..
I forgot to mention that it crash during an update few years ago… yes.. the radio is laying around for years now! lol

Chouby69

EDIT: all ribbon are well connected.. I check yesterday and the battery is full
Back to the top

Post

Im sure there is an audio filter that has gone bad along with the display if nothing is showing up. Does the radio function with PTT at all? Sometimes the radio can still operate. Is there any flashing on the LED indicator light for either transmit or recieve? The CP185 is definitely one of my least of motorola radios.

You should upgrade

Back to the top

Post

Chouby69 said


I forgot to mention that it crash during an update few years ago

Chouby69

probably corrupted firmware or codeplug  

location USA
Back to the top
1 guest and 0 members have just viewed this.