Skip navigation
Banner

Motorola MCX760 CPS

Post

Motorola MCX760 Programminig software.

Hi Guys,

I need to reprogram some older radios for our local Marine Rescue organisation. Does anyone have the CPS software for the Motorola MCX760?

Cheers,
Peter - VK2AN
Back to the top

Post

Hi Peter
did you manage to get a copy of the mcx760 cps?
i am also after a copy if anyone has it
regards
James
vk2vjz
Back to the top

Post

Last edit: by tech


Hobby and love to  the job done
Back to the top

Post

hi Tech
I have tried this but it fails to read the radio
maybe i am doing something wrong
Would you have the pinout for the programming cable?
regards
james
Back to the top

Post

Tell me error message that you are getting.and secondly what cable are you using .usb or serial cable.with usb you have profilic and ftdi . maybe if you google you will find pin out but the cable  is very cheap on ebay.some cable you can make and some you wont able to

Hobby and love to  the job done
Back to the top

Post

Hi Tech
Im using a rj45 mic connector to 25pin din that goes to rib box.
I used this setup many times on my gm339 / 338's without any issue.
The response i get is - no response from radio.
regards
James
Image result for motorola gm338 programming cable pinout

Last edit: by Tiberius

Back to the top

Post

Did you try using a differnt computer .it should work thought.it is that  trunking radio.uninstall the software and reinstall it and check for bad contact in female rj 45 jack is ok.keep me posted

Hobby and love to  the job done
Back to the top

Post

Hi Tech
i am using an old xp pc
will try another
'regards
james
Back to the top

Post

The diagram you are showing is for the mcs 2000 ,that cable cannot program the mcx 760 .it wont work

Hobby and love to  the job done
Back to the top

Post

Hi tech
would you know the pinout?
I thought it might seeing it works with the gm series
regards
James
Back to the top

Post

No i dont have it .but i will check on it for you

Hobby and love to  the job done
Back to the top

Post

thanks tech
Back to the top

Post

This is what i found hope this help- https://www.dk9jc.de/blog/equipment/134-ribless-interface-for-motorola-chinese-engineering If%20i%20found%20any%20more%20i%20will%20let%20you%20know. (https://www.dk9jc.de/blog/equipment/134-ribless-interface-for-motorola-chinese-engineering):thumbs: https://www.dk9jc.de/blog/equipment/134-ribless-interface-for-motorola-chinese-engineering (https://www.dk9jc.de/b…orola-chinese-engineering)

Hobby and love to  the job done
Back to the top

Post

Hi Tiberius,

I have just seen your message, sorry for the late reply. I managed to get hold of a version of MPT R00.08.05.exe and it worked with my MCX760 OK. I suspect that I got it from Hamfiles, but if you can't find it, let me know and I'll upload a copy. The version you have may be just as good, maybe "tech" can enlighten us further.
I am using a cable I got from Ebay that has an RJ45 on one end and a DB9 on the other end. If you have a laptop with a 9 pin serial com port, it will work fine, if not you will need a USB to 9 pin serial converter, preferably one that implements control leads. If you get really stuck, I can buzz the cable out and give you a pinout.
Cheers, Peter - VK2AN
 
Back to the top

Post

Great i was looking at the too as i check but that version i did not have in my archive glad to know everything worked out ok.you can upload your version that you so other members can benefit to.all ways good to have more that one version available

Hobby and love to  the job done
Back to the top

Post

Hi Peter
i am using the one posted here on hamfiles - R00.08.08.
I made a cable from the rib to the rear accessory connector as per the service manual for the gm1280 which i believe are physically the same just different firmware.
The radio is now responding with radio data invalid

i can see serial data is flowing both ways.
BTW - i made a mistake in the model number - its a 780 not the 760 but i believe they are similar
http://www.batlabs.com/images/rkn4083.gif (http://www.batlabs.com/images/rkn4083.gif)

regards
james
vk2vjz
Back to the top

Post

This message was generated automatically and sent to you due to your notification settings. You cannot reply.



A new member, mauicowboy, has joined HamFiles. You can view his/her profile at:
https://hamfiles.co.uk/index.php?page=members&type=view&id=mauicowboy
Back to the top

Post

So you make mistake with the model .but they are basically  the same .i sense of something wrong .but i will hope vk2an upload the sofware so you can try it .i will looked  in my archive for you to see if it is there.

Hobby and love to  the job done
Back to the top

Post

thanks Tech
Back to the top

Post

Hi Tiberius,
I have uploaded the software, just need to wait till its checked by site admin. I didn't use the Acc. connector, I just used the RJ45 on the front. You could try that if all else fails.

Cheers,
Peter
Back to the top
1 guest and 0 members have just viewed this.